CallFire Maintenance
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted over 4 years ago. Mar 26, 2015 - 14:24 PDT
Identified
The CallFire system is undergoing maintenance. This currently affects all reporting on our legacy platform. We are working to restore service as soon as possible.
Posted over 4 years ago. Mar 26, 2015 - 14:13 PDT