CallFire System Outage
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted over 4 years ago. May 15, 2015 - 12:28 PDT
Identified
We are currently experiencing a system outage with several products. Our engineers are aware of the situation and are working to resolve it. We apologize for the inconvenience.
Posted over 4 years ago. May 15, 2015 - 11:49 PDT