We are experiencing platform disruptions that are affecting application services, API calls, and logins. Systems will be intermittently operational. Thank you for your patience while we continue to investigate and work towards a fix.
Incident Report for CallFire
Resolved
All systems are operational since 5/26, with the exception of a brief and unrelated issue on 6/23.

Note that we will be deprecating this statuspage. Moving forward, please subscribe to our new statuspage https://status.eztexting.com/ where we will share updates for both the Callfire and EZ Texting brands.
Posted Jun 24, 2023 - 13:23 PDT
Update
Our emergency response team continues to monitor our systems 24/7. Our Engineers continue to work on several fixes and optimizations that are cumulatively working well. The platform has not had any downtime since Friday morning May 26th. We will continue to update once resolved.
Posted Jun 01, 2023 - 10:00 PDT
Monitoring
Update - The system is currently operational. We are continuing to monitor for intermittent platform disruptions.
Posted May 29, 2023 - 10:08 PDT
Update
We are currently operational, thank you for your patience.
Posted May 26, 2023 - 08:08 PDT
Update
We are experiencing platform disruptions that are affecting application services, API calls, and logins. Systems will be intermittently operational. Thank you for your patience while we continue to investigate and work towards a fix.
Posted May 26, 2023 - 07:23 PDT
Update
We are currently operational, thank you for your patience.
Posted May 25, 2023 - 16:23 PDT
Update
We are experiencing platform disruptions that are affecting application services, API calls, and logins. Systems will be intermittently operational. Thank you for your patience while we continue to investigate and work towards a fix.
Posted May 25, 2023 - 13:49 PDT
Update
We are currently operational, thank you for your patience.
Posted May 25, 2023 - 12:17 PDT
Update
We are experiencing platform disruptions that are affecting application services, API calls, and logins. Systems will be intermittently operational. Thank you for your patience while we continue to investigate and work towards a fix.
Posted May 25, 2023 - 10:39 PDT
Update
Our systems are currently up and running. Thank you for your patience
Posted May 25, 2023 - 09:33 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 25, 2023 - 09:07 PDT
Identified
We are experiencing platform disruptions that are affecting application services, API calls, and logins. Systems will be intermittently operational. Thank you for your patience while we continue to investigate and work towards a fix.
Posted May 25, 2023 - 09:06 PDT
This incident affected: API, Call Tracking, Cloud Call Center, IVR, SMS Text Messaging, and Voice Broadcast.