CallFire System Outage
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted over 4 years ago. Jun 05, 2015 - 22:52 PDT
Identified
We are currently experiencing a system outage. Our engineers are aware of the situation and are working to resolve it. We apologize for the inconvenience.
Posted over 4 years ago. Jun 05, 2015 - 22:11 PDT