Performance Degradation
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted over 3 years ago. Feb 08, 2016 - 08:27 PST
Investigating
CallFire systems are currently performing more slowly than usual. Please be advised that your campaigns continued to be processed. We expect performance to improve shortly.
Posted over 3 years ago. Feb 08, 2016 - 08:19 PST