CallFire System Delays
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted almost 5 years ago. Jan 07, 2015 - 12:07 PST
Identified
The CallFire platform is currently experiencing system delays. We are working to resolve the issue as quickly as possible.
Posted almost 5 years ago. Jan 07, 2015 - 11:48 PST