Website Performance Degradation
Incident Report for CallFire
Resolved
Website responsiveness has been resolved.
Posted over 4 years ago. Mar 02, 2015 - 12:57 PST
Identified
The CallFire website is currently performing slower than usual. Please be advised that your campaigns continue to be processed. We expect performance to improve shortly.
Posted over 4 years ago. Mar 02, 2015 - 12:27 PST