CallFire System Delays
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted over 4 years ago. May 14, 2015 - 16:27 PDT
Identified
The CallFire platform is currently experiencing system delays. We are working to resolve the issue as quickly as possible.
Posted over 4 years ago. May 14, 2015 - 15:01 PDT