67076 Short Code Issue
Incident Report for CallFire
Resolved
The provider has resolved the issue. Text messages from the 67076 short code are now working.
Posted over 4 years ago. Feb 06, 2015 - 13:00 PST
Identified
Our provider is currently having issues delivering messages over the 67076 short code. We are working with them to resolve the issue as quickly as possible.
Posted over 4 years ago. Feb 06, 2015 - 12:48 PST