CallFire Legacy Emergency Maintenance
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted almost 5 years ago. Nov 03, 2014 - 15:22 PST
Investigating
The CallFire Legacy system is undergoing emergency maintenance. This currently affects all products on our platform: Voice Broadcast, Cloud Call Center, Call Tracking, and SMS Text Messaging. We are working to restore service as soon as possible.
Posted almost 5 years ago. Nov 03, 2014 - 15:16 PST