Performance Degradation
Incident Report for CallFire
Resolved
This incident has been resolved.
Posted almost 5 years ago. Nov 03, 2014 - 19:26 PST
Investigating
CallFire systems are currently performing more slowly than usual. Please be advised that your campaigns continued to be processed. We expect performance to improve shortly.
Posted almost 5 years ago. Nov 03, 2014 - 16:15 PST